ホーム > Uncategorized > [覚書][未完]ubuntuでrubyのmechanizeを使おうとおもったら、hoeがrubygemsの新しいバージョンを要求する

[覚書][未完]ubuntuでrubyのmechanizeを使おうとおもったら、hoeがrubygemsの新しいバージョンを要求する

これだこれ
$sudo gem install hoe[Enter]
ERROR: Error installing hoe:
hoe requires RubyGems version >= 1.3.1

よりによって、rubygems本体を更新しろとな。ウザ

こちらの手順によると

sudo gem update --system[Enter]

はubuntuでは無効にされていて不能

sudo gem install rubygems-update[Enter]
sudo update_rubygems[Enter]

が正解らしいのだが、なんか不安。

実際

sudo update_rubygems[Enter]

すると、update_rubygems not found.となる

どこにあるのか?

gem contents rubygems-update | grep -i rubygems$[Enter]
/var/lib/gems/1.8/gems/rubygems-update-1.3.4/bin/update_rubygems

やっと実行
それではってことで、Versionを確認

$gem –version[Enter]
1.2.0

あがってねーし

結局・・・


$sudo apt-get remove --purge rubygems1.8[Enter]

安易んストールして、rubygemsの最新版を手動インストールする。

広告
  1. まだコメントはありません。
  1. No trackbacks yet.

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

%d人のブロガーが「いいね」をつけました。