[覚書]gitをアップデートせよ!”Flutter version 0.0.0-unknown”や” The current Flutter SDK version is 0.0.0-unknown.”エラーの対策. [CentOS7][ロートルの処方箋]

 

Flutterでカメラを使おうとして3時間もハマった。

  • Flutterがあまりに凄すぎて、粋がっていたらコレだ。
  • 「俺はタコだ。世界で一番愚かなタコだ。」

「The current Flutter SDK version is 0.0.0-unknown.」とflutter doctorの「Flutter version 0.0.0-unknown」

  • さっぱり分かんねー
  •  オフィシャルのインストール手順には警告がない

ネット上にろくな情報がない

  • 一番優位な情報は、「https://github.com/flutter/flutter/wiki/Workarounds-for-common-issues#flutter-installation-corrupted」「https://qiita.com/akiakishitai/items/8287bd5616f2add17a25」でgitに問題がありそうなことを匂わせている。
  • ネット上にflutterのクローンを作って、そのバージョンを書き換えてみろとかある。

なんとなく gitを1.8.3から2.25.0にアップグレードしてみる

  • flutter/intenal/engine.versionが臭い
  • git clone gitする
  • INSTALLを読んで、追加ライブラリをyumでインストールして、make configureし、make allし、sudo make installし、/usr/local/bin/gitが完成。

解決

  • tarボールでインストールしたflutter doctorが正常にバージョンを返すようになる。
  • git cloneでインストールしたflutter doctorも正常にバージョンを返すようになる。

手順は要望があったら書こう。まあイランだろうが

コメントを投稿

Required fields are marked *
*
*

%d人のブロガーが「いいね」をつけました。